$re = '/(?|(\?)|&)ordem=\d+(?(1)(&|$))/m';
$str = 'http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2FFF';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;