re = /(?|(\?)|&)ordem=\d+(?(1)(&|$))/m
str = 'http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2FFF'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result