using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|(\?)|&)ordem=\d+(?(1)(&|$))";
string substitution = @"$1";
string input = @"http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2FFF";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}