package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|(\?)|&)ordem=\d+(?(1)(&|$))`)
var str = `http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2FFF`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}