$re = '~(Nokian|BFGoodrich|Pirelli|Toyo|Continental|Hankook|Mitas)\s+(.*?)\s+(\d+)/(\d+)\s*([a-z]+)(\d+)C?\s+([\/\d]+)([a-z]+)\s*([a-z]+)?\s*(RunFlat|Run Flat|ROF|ZP|SSR|ZPS|HRS|RFT)?\s*.*?\s*(TT|TL|TL/TT)~iu';
$str = 'Toyo H08 195/75R16C 107/105S TL Летние';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);