import re
regex = re.compile(r"(Nokian|BFGoodrich|Pirelli|Toyo|Continental|Hankook|Mitas)\s+(.*?)\s+(\d+)/(\d+)\s*([a-z]+)(\d+)C?\s+([\/\d]+)([a-z]+)\s*([a-z]+)?\s*(RunFlat|Run Flat|ROF|ZP|SSR|ZPS|HRS|RFT)?\s*.*?\s*(TT|TL|TL/TT)", flags=re.IGNORECASE | re.UNICODE)
test_str = "Toyo H08 195/75R16C 107/105S TL Летние"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")