using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)\?";
string input = @"https://www.pap.fr/annonces/appartement-paris-18e-75018-r430701902?a=17172977&email=marcjagu%40gmail.com&md5=661499763cc85bc35eac029437fb2057&utm_source=alerte_vente&utm_medium=email&utm_campaign=alerte_vente";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}