import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)\\?";
final String string = "https://www.pap.fr/annonces/appartement-paris-18e-75018-r430701902?a=17172977&email=marcjagu%40gmail.com&md5=661499763cc85bc35eac029437fb2057&utm_source=alerte_vente&utm_medium=email&utm_campaign=alerte_vente";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}