#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<((?:Student)?ID)>(\d+)</\1>"
Local $sString = "<StudentID>12345</StudentID>" & @CRLF & _
"Or it can be" & @CRLF & _
"" & @CRLF & _
"<ID>12345</ID>" & @CRLF & _
"The input can be" & @CRLF & _
"" & @CRLF & _
"<Somedata>SSS<Somedata><StudentID>12345</StudentID><Name>MMM</Name>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")