$re = '%<((?:Student)?ID)>(\d+)</\1>%';
$str = '<StudentID>12345</StudentID>
Or it can be
<ID>12345</ID>
The input can be
<Somedata>SSS<Somedata><StudentID>12345</StudentID><Name>MMM</Name>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);