import re
regex = re.compile(r"<((?:Student)?ID)>(\d+)</\1>")
test_str = ("<StudentID>12345</StudentID>\n"
"Or it can be\n\n"
"<ID>12345</ID>\n"
"The input can be\n\n"
"<Somedata>SSS<Somedata><StudentID>12345</StudentID><Name>MMM</Name>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")