re = /<((?:Student)?ID)>(\d+)<\/\1>/
str = '<StudentID>12345</StudentID>
Or it can be
<ID>12345</ID>
The input can be
<Somedata>SSS<Somedata><StudentID>12345</StudentID><Name>MMM</Name>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end