// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)R( .*)([/(])").unwrap();
let string = "Jan 31 15:28:15 ubuntu.local ticky: ERROR Permission denied while closing ticket (enim.non)";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}