#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\?|\&)([tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B\[0-9\]%5D=]+)\=([^&]+)"
Local $sString = "?tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B0%5D=2&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1%5D=6&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1%5D=2&cHash=0bc48e5ae84bdb2805e9297feecd3a84&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1334%5D=244"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")