using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\?|\&)([tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B\[0-9\]%5D=]+)\=([^&]+)";
string input = @"?tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B0%5D=2&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1%5D=6&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1%5D=2&cHash=0bc48e5ae84bdb2805e9297feecd3a84&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1334%5D=244";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}