package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\?|\&)([tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B\[0-9\]%5D=]+)\=([^&]+)`)
var str = `?tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B0%5D=2&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1%5D=6&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1%5D=2&cHash=0bc48e5ae84bdb2805e9297feecd3a84&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1334%5D=244`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}