use strict;
my $str = '?tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B0%5D=2&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1%5D=6&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1%5D=2&cHash=0bc48e5ae84bdb2805e9297feecd3a84&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1334%5D=244';
my $regex = qr/(\?|\&)([tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B\[0-9\]%5D=]+)\=([^&]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}