import Foundation
let pattern = #"(\?|\&)([tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B\[0-9\]%5D=]+)\=([^&]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"?tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B0%5D=2&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1%5D=6&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1%5D=2&cHash=0bc48e5ae84bdb2805e9297feecd3a84&tx_dwtalentsconnectimporter_joblist%5Bfilter%5D%5BfilterIndustry%5D%5B1334%5D=244"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)