# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<(\w+)>)\s*(.*?)\s*(<\\/\2>)/\1\3\4/gm;t' <<< "<para> This is a test paragraph </para>"