import Foundation
let pattern = #"(<(\w+)>)\s*(.*?)\s*(<\/\2>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<para> This is a test paragraph </para>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\3\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)