use strict;
my $str = '<para> This is a test paragraph </para>';
my $regex = qr/(<(\w+)>)\s*(.*?)\s*(<\/\2>)/mp;
my $subst = '\\1\\3\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";