$re = '/(<(\w+)>)\s*(.*?)\s*(<\/\2>)/m';
$str = '<para> This is a test paragraph </para>';
$subst = "\1\3\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;