using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^,]+)[, ]+(\w+) (\w+)";
string substitution = @"\1,\2 \3";
string input = @"new york, ,ny usa ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}