$re = '/([^,]+)[, ]+(\w+) (\w+)/m';
$str = 'new york, ,ny usa ';
$subst = "\1,\2 \3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;