use strict;
my $str = 'new york, ,ny usa ';
my $regex = qr/([^,]+)[, ]+(\w+) (\w+)/mp;
my $subst = '\\1,\\2 \\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";