import Foundation
let pattern = #"([^,]+)[, ]+(\w+) (\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"new york, ,ny usa "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1,\2 \3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)