re = /([^,]+)[, ]+(\w+) (\w+)/m
str = 'new york, ,ny usa '
subst = '\\1,\\2 \\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result