using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^01[3-9]\d{8}$";
string input = @"7777777778
90332433443
01552377459
01203345454
01307728289";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}