re = /^01[3-9]\d{8}$/m
str = '7777777778
90332433443
01552377459
01203345454
01307728289'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end