const regex = /^01[3-9]\d{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^01[3-9]\\d{8}$', 'gm')
const str = `7777777778
90332433443
01552377459
01203345454
01307728289`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}