$re = '/^01[3-9]\d{8}$/m';
$str = '7777777778
90332433443
01552377459
01203345454
01307728289';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);