#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[\s]*javascript:[\s]*m\((-?\d+)[\s]*,[\s]*(-?\d+)[\s]*,[\s]{0,}encodeURIComponent\(\'([^\']+)*\'\)[\s]*,[\s]*(-?\d+)\)[\s]*"
Local $sString = "javascript:m(53009,2,encodeURIComponent('7711T'), 22)" & @CRLF & _
"javascript:m(52992,2,encodeURIComponent('3013'), 2)" & @CRLF & _
"javascript:m(10440,2,encodeURIComponent('Forterra Series'), 11)" & @CRLF & _
"javascript:m(53022,2,encodeURIComponent('Crystal 12045'), 85)" & @CRLF & _
"javascript:m(53045,2,encodeURIComponent('Proxima 8441'), 16)" & @CRLF & _
"javascript:m(26016,2,encodeURIComponent('Vard asd .ious'), 22)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")