import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s]*javascript:[\\s]*m\\((-?\\d+)[\\s]*,[\\s]*(-?\\d+)[\\s]*,[\\s]{0,}encodeURIComponent\\(\\'([^\\']+)*\\'\\)[\\s]*,[\\s]*(-?\\d+)\\)[\\s]*";
final String string = "javascript:m(53009,2,encodeURIComponent('7711T'), 22)\n"
+ "javascript:m(52992,2,encodeURIComponent('3013'), 2)\n"
+ "javascript:m(10440,2,encodeURIComponent('Forterra Series'), 11)\n"
+ "javascript:m(53022,2,encodeURIComponent('Crystal 12045'), 85)\n"
+ "javascript:m(53045,2,encodeURIComponent('Proxima 8441'), 16)\n"
+ "javascript:m(26016,2,encodeURIComponent('Vard asd .ious'), 22)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}