use strict;
my $str = 'javascript:m(53009,2,encodeURIComponent(\'7711T\'), 22)
javascript:m(52992,2,encodeURIComponent(\'3013\'), 2)
javascript:m(10440,2,encodeURIComponent(\'Forterra Series\'), 11)
javascript:m(53022,2,encodeURIComponent(\'Crystal 12045\'), 85)
javascript:m(53045,2,encodeURIComponent(\'Proxima 8441\'), 16)
javascript:m(26016,2,encodeURIComponent(\'Vard asd .ious\'), 22)';
my $regex = qr`[\s]*javascript:[\s]*m\((-?\d+)[\s]*,[\s]*(-?\d+)[\s]*,[\s]{0,}encodeURIComponent\(\'([^\']+)*\'\)[\s]*,[\s]*(-?\d+)\)[\s]*`mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}