# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\s]*javascript:[\s]*m\((-?\d+)[\s]*,[\s]*(-?\d+)[\s]*,[\s]{0,}encodeURIComponent\(\'([^\']+)*\'\)[\s]*,[\s]*(-?\d+)\)[\s]*"
test_str = ("javascript:m(53009,2,encodeURIComponent('7711T'), 22)\n"
"javascript:m(52992,2,encodeURIComponent('3013'), 2)\n"
"javascript:m(10440,2,encodeURIComponent('Forterra Series'), 11)\n"
"javascript:m(53022,2,encodeURIComponent('Crystal 12045'), 85)\n"
"javascript:m(53045,2,encodeURIComponent('Proxima 8441'), 16)\n"
"javascript:m(26016,2,encodeURIComponent('Vard asd .ious'), 22)")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.