$re = '/([\'"])(.*?)\1|i/';
$str = '"word1 word2" "word3 word4" word5 word6';
$subst = "\1&";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;