re = /([\'"])(.*?)\1|i/
str = '"word1 word2" "word3 word4" word5 word6'
subst = '\\1&'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result