import Foundation
let pattern = #"([\'"])(.*?)\1|i"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""word1 word2" "word3 word4" word5 word6"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1&"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)