import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:((?<=[\\s\\W])|^)[#](\\w+|[^#]|$)|((?<=[\\s\\W])|^)[@]([a-zA-Z0-9_]+|$))";
final String string = "This week, four astronauts arrived at @NASAKennedy for NASA's\n"
+ "@SpaceX Crew-1 launch to the @Space_Station. Their six-month mission will be filled with @ISS_Research, from technology demonstrations to space gardening. More on #SpaceToGround: http://youtu.be/bBKe3cuw-b8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}