re = /(?:((?<=[\s\W])|^)[#](\w+|[^#]|$)|((?<=[\s\W])|^)[@]([a-zA-Z0-9_]+|$))/m
str = 'This week, four astronauts arrived at @NASAKennedy for NASA\'s
@SpaceX Crew-1 launch to the @Space_Station. Their six-month mission will be filled with @ISS_Research, from technology demonstrations to space gardening. More on #SpaceToGround: http://youtu.be/bBKe3cuw-b8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end