use strict;
my $str = 'This week, four astronauts arrived at @NASAKennedy for NASA\'s
@SpaceX Crew-1 launch to the @Space_Station. Their six-month mission will be filled with @ISS_Research, from technology demonstrations to space gardening. More on #SpaceToGround: http://youtu.be/bBKe3cuw-b8';
my $regex = qr/(?:((?<=[\s\W])|^)[#](\w+|[^#]|$)|((?<=[\s\W])|^)[@]([a-zA-Z0-9_]+|$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}