const regex = /(?:((?<=[\s\W])|^)[#](\w+|[^#]|$)|((?<=[\s\W])|^)[@]([a-zA-Z0-9_]+|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:((?<=[\\s\\W])|^)[#](\\w+|[^#]|$)|((?<=[\\s\\W])|^)[@]([a-zA-Z0-9_]+|$))', 'gm')
const str = `This week, four astronauts arrived at @NASAKennedy for NASA's
@SpaceX Crew-1 launch to the @Space_Station. Their six-month mission will be filled with @ISS_Research, from technology demonstrations to space gardening. More on #SpaceToGround: http://youtu.be/bBKe3cuw-b8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}