using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9]+_[a-zA-Z0-9]+_[a-zA-Z0-9]+$";
string input = @"SOM_P9ERR96M27VP4_PL
SOM__P9QTR96M27VP4PL";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}