re = /^[a-zA-Z0-9]+_[a-zA-Z0-9]+_[a-zA-Z0-9]+$/m
str = 'SOM_P9ERR96M27VP4_PL
SOM__P9QTR96M27VP4PL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end