$re = '/^[a-zA-Z0-9]+_[a-zA-Z0-9]+_[a-zA-Z0-9]+$/m';
$str = 'SOM_P9ERR96M27VP4_PL
SOM__P9QTR96M27VP4PL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);