using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[^j\n]*j)(?=[^a\n]*a)(?=[^n\n]*n)[jan]+$";
string input = @"jan
jana
anj
naj
najana
...
but shouldn't catch these strings:
ana
jaa
nj
aa
nn
a
n
j
..";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}