import re
regex = re.compile(r"^(?=[^j\n]*j)(?=[^a\n]*a)(?=[^n\n]*n)[jan]+$", flags=re.MULTILINE)
test_str = ("jan\n"
"jana\n"
"anj\n"
"naj\n"
"najana\n"
"...\n"
"but shouldn't catch these strings:\n\n"
"ana\n"
"jaa\n"
"nj\n"
"aa\n"
"nn\n"
"a\n"
"n\n"
"j\n"
"..")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")