$re = '/^(?=[^j\n]*j)(?=[^a\n]*a)(?=[^n\n]*n)[jan]+$/m';
$str = 'jan
jana
anj
naj
najana
...
but shouldn\'t catch these strings:
ana
jaa
nj
aa
nn
a
n
j
..';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);