re = /^(?=[^j\n]*j)(?=[^a\n]*a)(?=[^n\n]*n)[jan]+$/m
str = 'jan
jana
anj
naj
najana
...
but shouldn\'t catch these strings:
ana
jaa
nj
aa
nn
a
n
j
..'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end