import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^j\\n]*j)(?=[^a\\n]*a)(?=[^n\\n]*n)[jan]+$";
final String string = "jan\n"
+ "jana\n"
+ "anj\n"
+ "naj\n"
+ "najana\n"
+ "...\n"
+ "but shouldn't catch these strings:\n\n"
+ "ana\n"
+ "jaa\n"
+ "nj\n"
+ "aa\n"
+ "nn\n"
+ "a\n"
+ "n\n"
+ "j\n"
+ "..";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}